Router | 路由器折腾记

前言:
大概是大二的时候入手的WNDR4300,那时候学校大神弄了个路由器免拨号上网的东西,但需要在openwrt路由器固件上跑个py脚本,从此打开了刷路由器的大门,最近家里刚装上了宽带,吃灰已久的WNDR4300又拿出来开始它未完的折腾之路...

正文:

批量安装更新脚本:

opkg update
opkg list-upgradable | awk -F ' - ' '{print $1}' | xargs opkg upgrade

*Openwrt/LEDE 在U盘上做 extroot

*再次折腾我的WNDR4300:OpenWrt文件共享

*斐讯k3搭建nginx+php+MariaDB(mysql )的教程

*原创 单臂路由之openwrt vlan实现

*tb of K3

K3:

  1. 格式化U盘为ext4并挂载:插上自动挂载
  2. 创建swap文件

    dd if=/dev/zero of=/mnt/sda1/swapfile bs=1M count=1024
    mkswap /mnt/sda1/swapfile
    swapon /mnt/sda1/swapfile
    
    vi /etc/fsatb
    > /mnt/sda1/swapfile    swap    swap    defaults    0  0
    swapon -a
  3. 安装entware环境

    entware-setup.sh
  4. 安装onmp环境【来源

    cd /mnt/sda1 && sh -c "$(curl -kfsSL https://raw.githubusercontent.com/xzhih/ONMP/master/oneclick.sh)"
  5. 使用onmp一键安装Netcloud云盘

    onmp open

    !> 荒野无灯相关

恩山主页:https://www.right.com.cn/forum/space-uid-316501.html

frp服务器一键部署 + 荒野无灯版p4davan frp 客户端 配置教程

N1固件 - PT下载小钢炮固件 (docker和jellyfin测试工作OK)")

码云地址:https://gitee.com/8ox86

一键部署frps:https://frps-deploy.80x86.io

J3455 UNRAID OpenWrt 网络配置

config interface 'lan'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.6.100'
        option netmask '255.255.255.0'
        option multipath 'off'
        option gateway '192.168.6.1'
        option broadcast '192.168.6.0'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'

# service network restart
# 解决半双工 
ethtool -s eth0 speed 1000 duplex full
# 永久解决 
vi /etc/init.d/network
start_service() {                                                                                                               
    ......
    ethtool -s eth0 speed 1000 duplex full                                                                                      }

参考:
openwrt一些参考

未完待续...

本文链接:

https://blog.zhigu34.cn/archives/router.html
1 + 8 =
2 评论
    zhigu34Chrome 70Windows 10
    2018年12月09日 回复

    三千预算进卡吧,加钱加到十万八。
    十核 E7装上去,四路泰坦抱回家。
    4K 屏幕组三屏,万元液态温度压。
    固态硬盘装三块,硬盘内存使劲加。
    键鼠必花几千元,耳机手柄八千八。
    还有机箱六千元,红星炸弹啪啪啪。

    最后发现没啥用,抱着神机刷贴吧。

    三千预算进图吧,一吨配置抱回家。
    四核至强装上去,老旧主板笑哈哈。
    蓝光电影皆不惧,青鸟散热是最佳。
    最多一块破金胜,专用内存使劲加。
    键鼠一共九块九,外设包邮八块八。
    还是裸奔散热好,工包电源顶呱呱。
    最后发现奶太多,学校对面开网吧。